LACP – bonding cisco switch

Ukázka LACP dual Gigabit port mezi switchi

cisco LACP

hostname switch0
!
interface GigabitEthernet1/1
 channel-group 1 mode active
 switchport mode trunk
!
interface GigabitEthernet1/2
 channel-group 1 mode active
 switchport mode trunk
!
interface Port-channel 1
 description trunk na druhej switch
 switchport mode trunk
hostname switch1
!
interface GigabitEthernet1/1
 channel-group 1 mode passive
 switchport mode trunk
!
interface GigabitEthernet1/2
 channel-group 1 mode passive
 switchport mode trunk
!
interface Port-channel 1
 description trunk na druhej switch
 switchport mode trunk
!

Ukázka v CPT  s2switcheLACP

Pro linux se používá termín Bonding  viz.: http://backdrift.org/howtonetworkbonding

cisco zjištění statusu jak se chová LACP

switch0#sh interfaces etherchannel
GigabitEthernet1/1:
Port state    = 1
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs

        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Fa1/1     SA      down      32768         0x0       0x0     0x25         

Partner's information:
                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Fa1/1     SA      32768     000D.BD75.75BB         0x0    0x0    0x25     

Age of the port in the current state:  00d:00h:22m:04s

GigabitEthernet1/2:
Port state    = 1
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs

        A - Device is in active mode.        P - Device is in passive mode.

Local information:
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Fa1/2     SA      down      32768         0x0       0x0     0x26         

Partner's information:
                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Fa1/2     SA      32768     000D.BD75.75BB         0x0    0x0    0x26     

Age of the port in the current state:  00d:00h:22m:04s

----
Port-channel1:Port-channel1   (Primary aggregator)
Age of the Port-channel   = 00d:00h:28m:56s
Logical slot/port   = 2/1             Number of ports = 2
HotStandBy port = null
Port state          = 
Protocol            =   1
Port Security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Gig1/2   Active             0
  0     00     Gig1/1   Active             0
Time since last port bundled:    00d:00h:22m:04s    Gig1/1

ukol portchannel

3-2-1-4-lab-configuring-etherchannel