ipv6to4 tunnel technologie

ipv6to4

 

 

 

 
ipv6to4-tunnel-pkt

R1 config

!
interface Tunnel1
 no ip address
 mtu 1476
 ipv6 address CCCC::/64
 ipv6 ospf 1 area 0.0.0.0
 tunnel source GigabitEthernet0/0
 tunnel destination 192.168.0.2
 tunnel mode ipv6ip
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
 ipv6 dhcp server localipv6
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AAAA::/64
 ipv6 ospf 1 area 0.0.0.0
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ipv6 router ospf 1
 router-id 1.1.1.2
 log-adjacency-changes
!

R2 config

!
interface Tunnel1
 no ip address
 mtu 1476
 ipv6 address CCCC::1/64
 ipv6 ospf 1 area 0.0.0.0
 tunnel source GigabitEthernet0/0
 tunnel destination 192.168.0.1
 tunnel mode ipv6ip
!
!
interface GigabitEthernet0/0
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address BBBB::/64
 ipv6 enable
 ipv6 ospf 1 area 0.0.0.0
 ipv6 dhcp server localipv6
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ipv6 router ospf 1
 router-id 1.1.1.3
 log-adjacency-changes
!