Cisco subinterface 802.1Q

!!switch
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet0/1
 switchport mode trunk

!! router
int g0/0
 no sh
!
int g0/0.1
 encapsulation dot1Q 10
 ip add 192.168.10.1 255.255.255.0
!
int g0/0.2
 encapsulation dot1Q 20
 ip add 192.168.11.1 255.255.255.0

ciscoencapsubinterface